headstand

Redirect after login causing 404 errors

Recommended Posts

Hi,

 

I'm working on a custom project that involves a proprietary API for IPB. I've come across a strange issue that I believe is related to IPBWI.

 

For this project, I am using my API for authentication (among other things). This has been tested on multiple sites and is working correctly. I recently installed the API on a site running WordPress and IPBWI for WordPress, and we get the following issue:

 

1. Make a call to the API 

2. API receives call and authenticates successfully

3. API returns JSON response

4. Somehwere.... somehow.... I get back an HTTP Error 404, BUT it includes my JSON response that I am expecting. It also includes a bunch of wordpress cookies in the header.

 

An educated guess tells me that the problem is somewhere in forumsMemberSync.php. Is there even the slightest chance I could get a look at that code? Even for just that function? I have absolutely no way of troubleshooting right now and I'm dead in the water. Unless someone here happens to know why I would get a 404 after a successful call. Does it do a redirect? 

 

I'm just completely stumped. Any assistance would be appreciated.

 

Thank you.

Share this post


Link to post
Share on other sites

Hi,

 

unfortunately, I cannot give you a view on the sourcecode, but of course, I'm offering support for active customers of my software to get it compatible to other probritary software. I'll provide your further details via reply on the email you've sent me.

 

Kind regards,

 

Matthias

Share this post


Link to post
Share on other sites